    <!doctype html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="https://gmpg.org/xfn/11">

        <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<script type="text/javascript">
var trackScrolling=false;
var trackScrollingPercentage=false;
var ScrollingPercentageNumber=25;
var stLogInterval=10*1000;
var cutOffTime=900;
var trackNoEvents=false;
var trackNoMaxTime=false;
var docTitle='It sucked to fall prey to this primitive squid';
</script>

	<!-- This site is optimized with the Yoast SEO plugin v19.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>It sucked to fall prey to this primitive squid</title><link rel="preload" as="style" href="https://fonts.googleapis.com/css?family=Lato%3A400%2C300%2C400italic%2C900%2C700%7CRoboto%3A100%2C300%2C400%2C500%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato%3A400%2C300%2C400italic%2C900%2C700%7CRoboto%3A100%2C300%2C400%2C500%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" media="print" onload="this.media='all'" /><noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato%3A400%2C300%2C400italic%2C900%2C700%7CRoboto%3A100%2C300%2C400%2C500%2C700&#038;subset=latin%2Clatin-ext&#038;display=swap" /></noscript>
	<link rel="canonical" href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="It sucked to fall prey to this primitive squid" />
	<meta property="og:description" content="You don&#8217;t want to find yourself in the arms of that ancient squid &#8211; which is related to the still-living vampire squid. This type of" />
	<meta property="og:url" content="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/" />
	<meta property="og:site_name" content="DodoFinance" />
	<meta property="article:published_time" content="2022-06-27T03:28:19+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Phil Schwartz" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://dodofinance.com/#organization","name":"DodoFinance","url":"https://dodofinance.com/","sameAs":[],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dodofinance.com/#/schema/logo/image/","url":"https://dodofinance.com/wp-content/uploads/2020/08/Logo.png","contentUrl":"https://dodofinance.com/wp-content/uploads/2020/08/Logo.png","width":335,"height":188,"caption":"DodoFinance"},"image":{"@id":"https://dodofinance.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://dodofinance.com/#website","url":"https://dodofinance.com/","name":"DodoFinance","description":"Breaking News Made For You!","publisher":{"@id":"https://dodofinance.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://dodofinance.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#primaryimage","url":"https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio.png","contentUrl":"https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio.png","width":1200,"height":675,"caption":"A spider's web as an eardrum | BNR news radio"},{"@type":"WebPage","@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#webpage","url":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/","name":"It sucked to fall prey to this primitive squid","isPartOf":{"@id":"https://dodofinance.com/#website"},"primaryImageOfPage":{"@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#primaryimage"},"datePublished":"2022-06-27T03:28:19+00:00","dateModified":"2022-06-27T03:28:19+00:00","breadcrumb":{"@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/"]}]},{"@type":"BreadcrumbList","@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"It sucked to fall prey to this primitive squid"}]},{"@type":"NewsArticle","@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#article","isPartOf":{"@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#webpage"},"author":{"@id":"https://dodofinance.com/#/schema/person/c8935d2cdf545ca844d0082265854f75"},"headline":"It sucked to fall prey to this primitive squid","datePublished":"2022-06-27T03:28:19+00:00","dateModified":"2022-06-27T03:28:19+00:00","mainEntityOfPage":{"@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#webpage"},"wordCount":200,"commentCount":0,"publisher":{"@id":"https://dodofinance.com/#organization"},"image":{"@id":"https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#primaryimage"},"thumbnailUrl":"https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio.png","articleSection":["science"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/#respond"]}]},{"@type":"Person","@id":"https://dodofinance.com/#/schema/person/c8935d2cdf545ca844d0082265854f75","name":"Phil Schwartz","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://dodofinance.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/425e4d17c18a616475d4c7633aef4adc?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/425e4d17c18a616475d4c7633aef4adc?s=96&d=mm&r=g","caption":"Phil Schwartz"},"description":"\"Food expert. Unapologetic bacon maven. Beer enthusiast. Pop cultureaholic. General travel scholar. Total internet buff.\"","url":"https://dodofinance.com/author/frosty-dirac/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link href='https://fonts.gstatic.com' crossorigin rel='preconnect' />
<link rel="alternate" type="application/rss+xml" title="DodoFinance &raquo; Feed" href="https://dodofinance.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="DodoFinance &raquo; Comments Feed" href="https://dodofinance.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="DodoFinance &raquo; It sucked to fall prey to this primitive squid Comments Feed" href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/feed/" />
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://dodofinance.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://dodofinance.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://dodofinance.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://dodofinance.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://dodofinance.com/wp-content/themes/magnitude-pro/assets/font-awesome/css/font-awesome.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://dodofinance.com/wp-content/themes/magnitude-pro/assets/bootstrap/css/bootstrap.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css-css'  href='https://dodofinance.com/wp-content/themes/magnitude-pro/assets/slick/css/slick.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='sidr-css'  href='https://dodofinance.com/wp-content/themes/magnitude-pro/assets/sidr/css/jquery.sidr.dark.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-css'  href='https://dodofinance.com/wp-content/themes/magnitude-pro/assets/magnific-popup/magnific-popup.css?ver=5.9' type='text/css' media='all' />

<link rel='stylesheet' id='magnitude-style-css'  href='https://dodofinance.com/wp-content/themes/magnitude-pro/style.css?ver=5.9' type='text/css' media='all' />
<style id='magnitude-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='jetpack_css-css'  href='https://dodofinance.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://dodofinance.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' data-cfasync='true' id='jquery-core-js' defer></script>

<script type='text/javascript' id='jquery-js-after'>window.addEventListener('DOMContentLoaded', function() {
jQuery(document).ready(function() {
	jQuery(".8bdf68100654e26a515d4140ee9a7c65").click(function() {
		jQuery.post(
			"https://dodofinance.com/wp-admin/admin-ajax.php", {
				"action": "quick_adsense_onpost_ad_click",
				"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
				"quick_adsense_nonce": "779c8fe01c",
			}, function(response) { }
		);
	});
});
});</script>
<script type='text/javascript' id='cfmonitor-js-extra'>
/* <![CDATA[ */
var cfmonitor = {"client_ip":"35.173.238.138","max_clicks":"2","clicks":"0","is_blocked":"0","customclass":"","disablead":"false","currentURL":"\/it-sucked-to-fall-prey-to-this-primitive-squid\/","debug":"true","caching":"1","ajaxurl":"https:\/\/dodofinance.com\/wp-admin\/admin-ajax.php","nonce":"309d014d94"};
/* ]]> */
</script>


<link rel="https://api.w.org/" href="https://dodofinance.com/wp-json/" /><link rel="alternate" type="application/json" href="https://dodofinance.com/wp-json/wp/v2/posts/36820" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://dodofinance.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://dodofinance.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9" />
<link rel='shortlink' href='https://dodofinance.com/?p=36820' />
<link rel="alternate" type="application/json+oembed" href="https://dodofinance.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdodofinance.com%2Fit-sucked-to-fall-prey-to-this-primitive-squid%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://dodofinance.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fdodofinance.com%2Fit-sucked-to-fall-prey-to-this-primitive-squid%2F&#038;format=xml" />
<link rel="preconnect" href="https://cdnjs.cloudflare.com">
		<!-- GA Google Analytics @ https://m0n.co/ga -->
		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-176716737-1', 'auto');
			ga('send', 'pageview');
		</script>

	<script data-ad-client="ca-pub-5061020171259996" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><style type='text/css'>img#wpstats{display:none}</style>
	<link rel="pingback" href="https://dodofinance.com/xmlrpc.php">        <style type="text/css">
                        .site-title,
            .site-description {
                position: absolute;
                clip: rect(1px, 1px, 1px, 1px);
                display: none;
            }

            

        </style>
        <style type="text/css">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</style><link rel="icon" href="https://dodofinance.com/wp-content/uploads/2020/08/Favicon.png" sizes="32x32" />
<link rel="icon" href="https://dodofinance.com/wp-content/uploads/2020/08/Favicon.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://dodofinance.com/wp-content/uploads/2020/08/Favicon.png" />
<meta name="msapplication-TileImage" content="https://dodofinance.com/wp-content/uploads/2020/08/Favicon.png" />
<noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript>    </head>

<body data-rsssl=1 class="post-template-default single single-post postid-36820 single-format-standard wp-custom-logo aft-default-mode aft-secondary-solid-color aft-header-layout-default widget-title-border-bottom default-content-layout align-content-left ">


<div id="page" class="site af-whole-wrapper">
    <a class="skip-link screen-reader-text" href="#content">Skip to content</a>


        <header id="masthead" class="header-layout-default magnitude-header">
            <div class="top-header">
    <div class="container-wrapper">
        <div class="top-bar-flex">
            <div class="top-bar-left col-2">
                                <div class="date-bar-left">
                                <span class="topbar-date">
        Mon. Jun 27th, 2022     </span>
                        </div>
            </div>
            <div class="top-bar-right col-2">
                <div class="aft-small-social-menu">
                                                </div>
            </div>
        </div>
    </div>
</div>
<div class="af-middle-header " data-background="">
    <div class="container-wrapper">
        <div class="af-middle-container">
            <div class="logo">
                        <div class="site-branding">
            <a href="https://dodofinance.com/" class="custom-logo-link" rel="home"><img width="335" height="188" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20335%20188'%3E%3C/svg%3E" class="custom-logo" alt="DodoFinance" data-lazy-srcset="https://dodofinance.com/wp-content/uploads/2020/08/Logo.png 335w, https://dodofinance.com/wp-content/uploads/2020/08/Logo-300x168.png 300w" data-lazy-sizes="(max-width: 335px) 100vw, 335px" data-lazy-src="https://dodofinance.com/wp-content/uploads/2020/08/Logo.png" /><noscript><img width="335" height="188" src="https://dodofinance.com/wp-content/uploads/2020/08/Logo.png" class="custom-logo" alt="DodoFinance" srcset="https://dodofinance.com/wp-content/uploads/2020/08/Logo.png 335w, https://dodofinance.com/wp-content/uploads/2020/08/Logo-300x168.png 300w" sizes="(max-width: 335px) 100vw, 335px" /></noscript></a>                <p class="site-title font-family-1">
                    <a href="https://dodofinance.com/" class="site-title-anchor"
                       rel="home">DodoFinance</a>
                </p>
            
                            <p class="site-description">Breaking News Made For You!</p>
                    </div>

                </div>
            <div class="header-advertise">
                            </div>
        </div>
    </div>
</div>
<div id="main-navigation-bar" class="af-bottom-header">
    <div class="container-wrapper">
        <div class="af-bottom-head-nav">
                    <div class="navigation-container">
            <nav class="main-navigation clearfix">

                                        <span class="toggle-menu" aria-controls="primary-menu" aria-expanded="false">
                                        <span class="screen-reader-text">
                                            Primary Menu                                        </span>
                                        <i class="ham"></i>
                                    </span>


                <div class="menu main-menu menu-desktop show-menu-border"><ul id="primary-menu" class="menu"><li id="menu-item-530" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://dodofinance.com">Home</a></li>
<li id="menu-item-531" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://dodofinance.com/top-news/">Top News</a></li>
<li id="menu-item-532" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://dodofinance.com/world/">World</a></li>
<li id="menu-item-533" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://dodofinance.com/economy/">Economy</a></li>
<li id="menu-item-534" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-534"><a href="https://dodofinance.com/science/">science</a></li>
<li id="menu-item-535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://dodofinance.com/tech/">Tech</a></li>
<li id="menu-item-536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://dodofinance.com/sport/">sport</a></li>
<li id="menu-item-537" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://dodofinance.com/entertainment/">entertainment</a></li>
<li id="menu-item-12440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12440"><a href="https://dodofinance.com/contact-form/">Contact Form</a></li>
</ul></div>            </nav>
        </div>

                        <div class="af-search-wrap">
            <div class="search-overlay">
                <a href="#" title="Search" class="search-icon">
                    <i class="fa fa-search"></i>
                </a>
                <div class="af-search-form">
                    <form role="search" method="get" class="search-form" action="https://dodofinance.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form>                </div>
            </div>
        </div>

            </div>
    </div>
</div>
    

        </header>

        <!-- end slider-section -->
        

    <div id="content" class="container-wrapper">


        <div class="af-breadcrumbs font-family-1 color-pad">
            <div role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://dodofinance.com" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://dodofinance.com/science/" itemprop="item"><span itemprop="name">science</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><span itemprop="item"><span itemprop="name">It sucked to fall prey to this primitive squid</span></span><meta itemprop="position" content="3" /></li></ul></div>        </div>


        <div id="primary" class="content-area">
        <main id="main" class="site-main">
                                <article id="post-36820" class="post-36820 post type-post status-publish format-standard has-post-thumbnail hentry category-science">

                        <div class="entry-content-wrap read-single social-after-title">
                                    <header class="entry-header pos-rel ">
            <div class="read-details">
                <div class="entry-header-details">
                    
                        <div class="figure-categories read-categories figure-categories-bg">
                                                        <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                        </div>
                                        <h1 class="entry-title">It sucked to fall prey to this primitive squid</h1>
                    <div class="aft-post-excerpt-and-meta color-pad pad ptb-10">
                                                
                                                <div class="entry-meta">

                            
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 hour ago            </span>
                
        </span>
                                    <span class="min-read">1 min read</span>                                <div class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            34            </span>
        </a>
        </span>
            </div>
                            </div>
                        
                    </div>
                </div>
            </div>
            

        </header><!-- .entry-header -->

                        <div class="read-img pos-rel">
                                    <div class="post-thumbnail full-width-image">
                    <img width="1024" height="576" src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%201024%20576'%3E%3C/svg%3E" class="attachment-magnitude-featured size-magnitude-featured wp-post-image" alt="A spider&#039;s web as an eardrum |  BNR news radio" data-lazy-srcset="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-1024x576.png 1024w, https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-300x169.png 300w, https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-768x432.png 768w, https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio.png 1200w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-1024x576.png" /><noscript><img width="1024" height="576" src="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-1024x576.png" class="attachment-magnitude-featured size-magnitude-featured wp-post-image" alt="A spider&#039;s web as an eardrum |  BNR news radio" srcset="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-1024x576.png 1024w, https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-300x169.png 300w, https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-768x432.png 768w, https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio.png 1200w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript>                </div>
            
                                            </div>

            

        <!-- end slider-section -->
                                    

    <div class="color-pad">
        <div class="entry-content read-details pad ptb-10">
            <div class="8bdf68100654e26a515d4140ee9a7c65" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Auto Ads New -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5061020171259996"
     data-ad-slot="6063956728"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<div>
<p>You don&#8217;t want to find yourself in the arms of that ancient squid &#8211; which is related to the still-living vampire squid.  </p>
<p>This type of squid lives at incredible depths, in oxygen-poor water.  They mainly eat floating organic particles.  The vampire squid and its ancestors are &#8211; or were &#8211; made of soft tissue.  </p>
<p>Hard to find in fossil form.  Still, researchers have gotten their hands on a few.  Ancient relatives, who must have lived about 200 million years ago.  They were only 10 centimeters tall, with 8 arms, an oval-shaped body and two fins. </p><div class="8bdf68100654e26a515d4140ee9a7c65" data-index="2" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Auto Ads New -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5061020171259996"
     data-ad-slot="6063956728"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p>Using the very latest techniques, they managed to extract new information from the fossils.  The pistons in particular &#8211; which they already had back then &#8211; were impressively sturdy and the nerves needed to detect prey weren&#8217;t bad either.  Despite the animal&#8217;s small size, it was not one you would have liked to encounter as a fish. </p>
<p>No, take today&#8217;s vampire squid, named after the color of its skin and the cloak-like webs between its tentacles.  It has completely embraced the languid deep-sea underwater life with its eight tentacles.  </p>
<p>Read more: <a target="_blank" href="https://www.eurekalert.org/news-releases/956750" rel="noopener noreferrer">It sucked being the prey of ancient cephalopods</a>†</p>
</div>
<div class="8bdf68100654e26a515d4140ee9a7c65" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Auto Ads New -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5061020171259996"
     data-ad-slot="6063956728"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div class="saboxplugin-wrap" itemtype="http://schema.org/Person" itemscope itemprop="author"><div class="saboxplugin-tab"><div class="saboxplugin-gravatar"><img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%20100%20100'%3E%3C/svg%3E" width="100"  height="100" alt="" itemprop="image" data-lazy-src="https://dodofinance.com/wp-content/uploads/2020/08/3.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2020/08/3.jpg" width="100"  height="100" alt="" itemprop="image"></noscript></div><div class="saboxplugin-authorname"><a href="https://dodofinance.com/author/frosty-dirac/" class="vcard author" rel="author" itemprop="url"><span class="fn" itemprop="name">Phil Schwartz</span></a></div><div class="saboxplugin-desc"><div itemprop="description"><p>&#8220;Food expert. Unapologetic bacon maven. Beer enthusiast. Pop cultureaholic. General travel scholar. Total internet buff.&#8221;</p>
</div></div><div class="clearfix"></div></div></div>                            <div class="post-item-metadata entry-meta">
                                    </div>
                        
	<nav class="navigation post-navigation" aria-label="Continue Reading">
		<h2 class="screen-reader-text">Continue Reading</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://dodofinance.com/iran-launches-controversial-missile-just-before-nuclear-program-talks-resume/" rel="prev"><span class="em-post-navigation">Previous:</span> Iran launches controversial missile just before nuclear program talks resume</a></div></div>
	</nav>                    </div><!-- .entry-content -->
    </div>
                        </div>

                        
<div id="comments" class="comments-area">

		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/it-sucked-to-fall-prey-to-this-primitive-squid/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://dodofinance.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><label for="comment">Comment <span class="required" aria-hidden="true">*</span></label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required" aria-hidden="true">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required /></p>
<p class="comment-form-email"><label for="email">Email <span class="required" aria-hidden="true">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='36820' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="640adba782" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="188"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

                        
<div class="promotionspace enable-promotionspace">

        <div class="af-reated-posts magnitude-customizer">
                            <h4 class="related-title widget-title header-after1">
                    <span class="header-after">
                        Related Stories                    </span>    
                </h4>
                        <div class="af-container-row clearfix">
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"
                                 data-background="https://dodofinance.com/wp-content/uploads/2022/06/Iran-launches-controversial-missile-just-before-nuclear-program-talks-resume-720x380.jpg">
                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Iran launches controversial missile just before nuclear program talks resume" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/Iran-launches-controversial-missile-just-before-nuclear-program-talks-resume-720x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/Iran-launches-controversial-missile-just-before-nuclear-program-talks-resume-720x380.jpg" alt="Iran launches controversial missile just before nuclear program talks resume"></noscript>
                                                         <a class="aft-post-image-link" href="https://dodofinance.com/iran-launches-controversial-missile-just-before-nuclear-program-talks-resume/">Iran launches controversial missile just before nuclear program talks resume</a>
                                                                <span class="min-read">1 min read</span>                                
                            </div>
                            <div class="read-details color-tp-pad pad ptb-10">

                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://dodofinance.com/iran-launches-controversial-missile-just-before-nuclear-program-talks-resume/">Iran launches controversial missile just before nuclear program talks resume</a>
                                    </h4>
                                </div>

                                <div class="entry-meta">
                                    
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        9 hours ago            </span>
                
        </span>
        
                                        <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/iran-launches-controversial-missile-just-before-nuclear-program-talks-resume/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            80            </span>
        </a>
        </span>

            </span>
                                    </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"
                                 data-background="https://dodofinance.com/wp-content/uploads/2022/06/Very-rare-frozen-baby-mammoth-discovered-in-Canada-Science-720x380.jpg">
                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Very rare frozen baby mammoth discovered in Canada |  Science" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/Very-rare-frozen-baby-mammoth-discovered-in-Canada-Science-720x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/Very-rare-frozen-baby-mammoth-discovered-in-Canada-Science-720x380.jpg" alt="Very rare frozen baby mammoth discovered in Canada |  Science"></noscript>
                                                         <a class="aft-post-image-link" href="https://dodofinance.com/very-rare-frozen-baby-mammoth-discovered-in-canada-science/">Very rare frozen baby mammoth discovered in Canada |  Science</a>
                                                                <span class="min-read">1 min read</span>                                
                            </div>
                            <div class="read-details color-tp-pad pad ptb-10">

                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://dodofinance.com/very-rare-frozen-baby-mammoth-discovered-in-canada-science/">Very rare frozen baby mammoth discovered in Canada |  Science</a>
                                    </h4>
                                </div>

                                <div class="entry-meta">
                                    
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        17 hours ago            </span>
                
        </span>
        
                                        <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/very-rare-frozen-baby-mammoth-discovered-in-canada-science/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            67            </span>
        </a>
        </span>

            </span>
                                    </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"
                                 data-background="https://dodofinance.com/wp-content/uploads/2022/06/Europes-Mars-Starship-Finally-Gets-an-Update-After-Windows-98-620x380.jpg">
                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Europe&#039;s Mars Starship Finally Gets an Update After Windows 98" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/Europes-Mars-Starship-Finally-Gets-an-Update-After-Windows-98-620x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/Europes-Mars-Starship-Finally-Gets-an-Update-After-Windows-98-620x380.jpg" alt="Europe&#039;s Mars Starship Finally Gets an Update After Windows 98"></noscript>
                                                         <a class="aft-post-image-link" href="https://dodofinance.com/europes-mars-starship-finally-gets-an-update-after-windows-98/">Europe&#8217;s Mars Starship Finally Gets an Update After Windows 98</a>
                                                                <span class="min-read">3 min read</span>                                
                            </div>
                            <div class="read-details color-tp-pad pad ptb-10">

                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://dodofinance.com/europes-mars-starship-finally-gets-an-update-after-windows-98/">Europe&#8217;s Mars Starship Finally Gets an Update After Windows 98</a>
                                    </h4>
                                </div>

                                <div class="entry-meta">
                                    
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 day ago            </span>
                
        </span>
        
                                        <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/europes-mars-starship-finally-gets-an-update-after-windows-98/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            105            </span>
        </a>
        </span>

            </span>
                                    </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"
                                 data-background="https://dodofinance.com/wp-content/uploads/2022/06/Science-is-also-just-an-opinion-Columns-720x380.jpg">
                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Science is also just an opinion |  Columns" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/Science-is-also-just-an-opinion-Columns-720x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/Science-is-also-just-an-opinion-Columns-720x380.jpg" alt="Science is also just an opinion |  Columns"></noscript>
                                                         <a class="aft-post-image-link" href="https://dodofinance.com/science-is-also-just-an-opinion-columns/">Science is also just an opinion |  Columns</a>
                                                                <span class="min-read">2 min read</span>                                
                            </div>
                            <div class="read-details color-tp-pad pad ptb-10">

                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://dodofinance.com/science-is-also-just-an-opinion-columns/">Science is also just an opinion |  Columns</a>
                                    </h4>
                                </div>

                                <div class="entry-meta">
                                    
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 day ago            </span>
                
        </span>
        
                                        <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/science-is-also-just-an-opinion-columns/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            126            </span>
        </a>
        </span>

            </span>
                                    </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"
                                 data-background="https://dodofinance.com/wp-content/uploads/2022/06/What-is-geoengineering-and-is-it-a-solution-to-climate.jpg">
                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="What is geoengineering and is it a solution to climate problems?" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/What-is-geoengineering-and-is-it-a-solution-to-climate.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/What-is-geoengineering-and-is-it-a-solution-to-climate.jpg" alt="What is geoengineering and is it a solution to climate problems?"></noscript>
                                                         <a class="aft-post-image-link" href="https://dodofinance.com/what-is-geoengineering-and-is-it-a-solution-to-climate-problems/">What is geoengineering and is it a solution to climate problems?</a>
                                                                <span class="min-read">2 min read</span>                                
                            </div>
                            <div class="read-details color-tp-pad pad ptb-10">

                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://dodofinance.com/what-is-geoengineering-and-is-it-a-solution-to-climate-problems/">What is geoengineering and is it a solution to climate problems?</a>
                                    </h4>
                                </div>

                                <div class="entry-meta">
                                    
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        2 days ago            </span>
                
        </span>
        
                                        <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/what-is-geoengineering-and-is-it-a-solution-to-climate-problems/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            140            </span>
        </a>
        </span>

            </span>
                                    </div>

                            </div>
                        </div>
                    </div>
                                    <div class="col-3 float-l pad latest-posts-grid af-sec-post" data-mh="latest-posts-grid">
                        <div class="read-single color-pad">
                            <div class="data-bg read-img pos-rel read-bg-img"
                                 data-background="https://dodofinance.com/wp-content/uploads/2022/06/1656127386_Why-regional-development-science-is-a-balancing-act-–-Area-720x380.jpg">
                                                                    <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Why regional development science is a balancing act – Area Development.nu" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/1656127386_Why-regional-development-science-is-a-balancing-act-–-Area-720x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/1656127386_Why-regional-development-science-is-a-balancing-act-–-Area-720x380.jpg" alt="Why regional development science is a balancing act – Area Development.nu"></noscript>
                                                         <a class="aft-post-image-link" href="https://dodofinance.com/why-regional-development-science-is-a-balancing-act-area-development-nu/">Why regional development science is a balancing act – Area Development.nu</a>
                                                                <span class="min-read">5 min read</span>                                
                            </div>
                            <div class="read-details color-tp-pad pad ptb-10">

                                <div class="read-categories">
                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                </div>
                                <div class="read-title">
                                    <h4>
                                        <a href="https://dodofinance.com/why-regional-development-science-is-a-balancing-act-area-development-nu/">Why regional development science is a balancing act – Area Development.nu</a>
                                    </h4>
                                </div>

                                <div class="entry-meta">
                                    
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        2 days ago            </span>
                
        </span>
        
                                        <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/why-regional-development-science-is-a-balancing-act-area-development-nu/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            125            </span>
        </a>
        </span>

            </span>
                                    </div>

                            </div>
                        </div>
                    </div>
                            </div>

    </div>
</div>


                    </article>
                
        </main><!-- #main -->
    </div><!-- #primary -->




<div id="secondary" class="sidebar-area aft-sticky-sidebar">
    <div class="theiaStickySidebar">
        <aside class="widget-area color-pad">
            <div id="adswidget1-quick-adsense-2" class="widget magnitude-widget widget_adswidget1-quick-adsense"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Auto Ads New -->
<ins class="adsbygoogle" data-ad-client="ca-pub-5061020171259996" data-ad-slot="6063956728"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div><div id="nav_menu-5" class="widget magnitude-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span>Navigate</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://dodofinance.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://dodofinance.com/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://dodofinance.com/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://dodofinance.com/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-534"><a href="https://dodofinance.com/science/">science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://dodofinance.com/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://dodofinance.com/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://dodofinance.com/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12440"><a href="https://dodofinance.com/contact-form/">Contact Form</a></li>
</ul></div></div><div id="pages-2" class="widget magnitude-widget widget_pages"><h2 class="widget-title widget-title-1"><span>Pages</span></h2>
			<ul>
				<li class="page_item page-item-413"><a href="https://dodofinance.com/about-us/">About Us</a></li>
<li class="page_item page-item-412"><a href="https://dodofinance.com/contact-form/">Contact Form</a></li>
<li class="page_item page-item-415"><a href="https://dodofinance.com/dmca/">DMCA</a></li>
<li class="page_item page-item-410"><a href="https://dodofinance.com/privacy-policy/">Privacy Policy</a></li>
			</ul>

			</div><div id="adswidget2-quick-adsense-2" class="widget magnitude-widget widget_adswidget2-quick-adsense"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Auto Ads New -->
<ins class="adsbygoogle" data-ad-client="ca-pub-5061020171259996" data-ad-slot="6063956728"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>        </aside>
    </div>
</div>

</div>


<div class="af-main-banner-latest-posts grid-layout magnitude-customizer">
    <div class="container-wrapper">
        <div class="widget-title-section">
                            <h4 class="widget-title header-after1">
                            <span class="header-after">
                                You may have missed                            </span>
                </h4>
            
        </div>
        <div class="af-container-row clearfix">
                        <div class="col-4 pad float-l " data-mh="af-feat-list">
                    <div class="read-single color-pad">
                        <div class="data-bg read-img pos-rel read-bg-img"
                             data-background="https://dodofinance.com/wp-content/uploads/2022/05/Possible-British-extradition-request-to-the-United-States-for-Kevin-720x380.jpg">
                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Possible British extradition request to the United States for Kevin Spacey" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/05/Possible-British-extradition-request-to-the-United-States-for-Kevin-720x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/05/Possible-British-extradition-request-to-the-United-States-for-Kevin-720x380.jpg" alt="Possible British extradition request to the United States for Kevin Spacey"></noscript>
                                                        <a class="aft-post-image-link" href="https://dodofinance.com/possible-british-extradition-request-to-the-united-states-for-kevin-spacey-2/">Possible British extradition request to the United States for Kevin Spacey</a>
                                                                <span class="min-read">1 min read</span>                                
                        </div>
                        <div class="read-details color-tp-pad pad ptb-10">

                            <div class="read-categories">
                                <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/entertainment/">
                                 entertainment
                             </a>
                        </li></ul>                            </div>
                            <div class="read-title">
                                <h4>
                                    <a href="https://dodofinance.com/possible-british-extradition-request-to-the-united-states-for-kevin-spacey-2/">Possible British extradition request to the United States for Kevin Spacey</a>
                                </h4>
                            </div>

                            <div class="entry-meta">
                                
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/muhammad/">
                Maggie Benson            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 hour ago            </span>
                
        </span>
        
                                    <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/possible-british-extradition-request-to-the-united-states-for-kevin-spacey-2/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            35            </span>
        </a>
        </span>

            </span>
                                </div>

                        </div>
                    </div>
                </div>
                            <div class="col-4 pad float-l " data-mh="af-feat-list">
                    <div class="read-single color-pad">
                        <div class="data-bg read-img pos-rel read-bg-img"
                             data-background="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-720x380.png">
                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="A spider&#039;s web as an eardrum |  BNR news radio" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-720x380.png"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-720x380.png" alt="A spider&#039;s web as an eardrum |  BNR news radio"></noscript>
                                                        <a class="aft-post-image-link" href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/">It sucked to fall prey to this primitive squid</a>
                                                                <span class="min-read">1 min read</span>                                
                        </div>
                        <div class="read-details color-tp-pad pad ptb-10">

                            <div class="read-categories">
                                <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                            </div>
                            <div class="read-title">
                                <h4>
                                    <a href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/">It sucked to fall prey to this primitive squid</a>
                                </h4>
                            </div>

                            <div class="entry-meta">
                                
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/frosty-dirac/">
                Phil Schwartz            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 hour ago            </span>
                
        </span>
        
                                    <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            34            </span>
        </a>
        </span>

            </span>
                                </div>

                        </div>
                    </div>
                </div>
                            <div class="col-4 pad float-l " data-mh="af-feat-list">
                    <div class="read-single color-pad">
                        <div class="data-bg read-img pos-rel read-bg-img"
                             data-background="https://dodofinance.com/wp-content/uploads/2022/06/Short-Game-Serbia-wins-3x3-Basketball-World-Championship-Sports-720x380.jpg">
                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Short Game: Serbia wins 3x3 Basketball World Championship |  Sports" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/Short-Game-Serbia-wins-3x3-Basketball-World-Championship-Sports-720x380.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/Short-Game-Serbia-wins-3x3-Basketball-World-Championship-Sports-720x380.jpg" alt="Short Game: Serbia wins 3x3 Basketball World Championship |  Sports"></noscript>
                                                        <a class="aft-post-image-link" href="https://dodofinance.com/sporty-shorts-serbia-win-3x3-basketball-world-title-sport/">Sporty shorts: Serbia win 3&#215;3 basketball world title |  sport</a>
                                                                <span class="min-read">7 min read</span>                                
                        </div>
                        <div class="read-details color-tp-pad pad ptb-10">

                            <div class="read-categories">
                                <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/sport/">
                                 sport
                             </a>
                        </li></ul>                            </div>
                            <div class="read-title">
                                <h4>
                                    <a href="https://dodofinance.com/sporty-shorts-serbia-win-3x3-basketball-world-title-sport/">Sporty shorts: Serbia win 3&#215;3 basketball world title |  sport</a>
                                </h4>
                            </div>

                            <div class="entry-meta">
                                
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/reyansh/">
                Queenie Bell            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 hour ago            </span>
                
        </span>
        
                                    <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/sporty-shorts-serbia-win-3x3-basketball-world-title-sport/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            40            </span>
        </a>
        </span>

            </span>
                                </div>

                        </div>
                    </div>
                </div>
                            <div class="col-4 pad float-l " data-mh="af-feat-list">
                    <div class="read-single color-pad">
                        <div class="data-bg read-img pos-rel read-bg-img"
                             data-background="https://dodofinance.com/wp-content/uploads/2022/06/1656300204_Xbox-Game-Bar-Insider-build-shows-if-your-PC-supports.jpg">
                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Xbox Game Bar Insider build shows if your PC supports DirectStorage" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/1656300204_Xbox-Game-Bar-Insider-build-shows-if-your-PC-supports.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/1656300204_Xbox-Game-Bar-Insider-build-shows-if-your-PC-supports.jpg" alt="Xbox Game Bar Insider build shows if your PC supports DirectStorage"></noscript>
                                                        <a class="aft-post-image-link" href="https://dodofinance.com/xbox-game-bar-insider-build-shows-if-your-pc-supports-directstorage/">Xbox Game Bar Insider build shows if your PC supports DirectStorage</a>
                                                                <span class="min-read">1 min read</span>                                
                        </div>
                        <div class="read-details color-tp-pad pad ptb-10">

                            <div class="read-categories">
                                <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/tech/">
                                 Tech
                             </a>
                        </li></ul>                            </div>
                            <div class="read-title">
                                <h4>
                                    <a href="https://dodofinance.com/xbox-game-bar-insider-build-shows-if-your-pc-supports-directstorage/">Xbox Game Bar Insider build shows if your PC supports DirectStorage</a>
                                </h4>
                            </div>

                            <div class="entry-meta">
                                
            <span class="author-links">

                
                    <span class="item-metadata posts-author byline">

            <a href="https://dodofinance.com/author/muhammad/">
                Maggie Benson            </a>
        </span>
                
                                    <span class="item-metadata posts-date">

                        1 hour ago            </span>
                
        </span>
        
                                    <span class="aft-comment-view-share">
                    <span class="aft-view-count">
        <a href="https://dodofinance.com/xbox-game-bar-insider-build-shows-if-your-pc-supports-directstorage/">
            <i class="fa fa-eye" aria-hidden="true"></i>
            <span class="aft-show-hover">
            34            </span>
        </a>
        </span>

            </span>
                                </div>

                        </div>
                    </div>
                </div>
                            </div>
    </div>
</div>

        <section class="aft-blocks above-footer-widget-section">
            <div class="container-wrapper">
                            </div>
        </section>

        
<footer class="site-footer">
    
        <div class="primary-footer">
        <div class="container-wrapper">
            <div class="af-container-row">
                                    <div class="primary-footer-area footer-first-widgets-section col-3 float-l pad">
                        <section class="widget-area color-pad">
                                <div id="text-4" class="widget magnitude-widget widget_text"><h2 class="widget-title widget-title-1"><span class="header-after">QUERIES?</span></h2>			<div class="textwidget"><p>Do you have any queries? Feel free to contact us via our <a href="https://dodofinance.com/contact-form/" target="_blank" rel="noopener">Contact Form</a></p>
</div>
		</div>                        </section>
                    </div>
                
                                    <div class="primary-footer-area footer-second-widgets-section  col-3 float-l pad">
                        <section class="widget-area color-pad">
                            <div id="nav_menu-4" class="widget magnitude-widget widget_nav_menu"><h2 class="widget-title widget-title-1"><span class="header-after">Navigate</span></h2><div class="menu-primary-menu-container"><ul id="menu-primary-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-530"><a href="https://dodofinance.com">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-531"><a href="https://dodofinance.com/top-news/">Top News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-532"><a href="https://dodofinance.com/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-533"><a href="https://dodofinance.com/economy/">Economy</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-534"><a href="https://dodofinance.com/science/">science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-535"><a href="https://dodofinance.com/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-536"><a href="https://dodofinance.com/sport/">sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-537"><a href="https://dodofinance.com/entertainment/">entertainment</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-12440"><a href="https://dodofinance.com/contact-form/">Contact Form</a></li>
</ul></div></div>                        </section>
                    </div>
                
                                    <div class="primary-footer-area footer-third-widgets-section  col-3 float-l pad">
                        <section class="widget-area color-pad">
                            <div id="text-7" class="widget magnitude-widget widget_text"><h2 class="widget-title widget-title-1"><span class="header-after">STAY UPTODATE</span></h2>			<div class="textwidget"><p>Get the Latest News With DodoFinance</p>
</div>
		</div><div id="magnitude_posts_list-3" class="widget magnitude-widget magnitude_posts_list list-layout">                        <div class="af-title-subtitle-wrap">
                                    <h4 class="widget-title header-after1">
                        <span class="header-after">
                            Posts List                            </span>
                    </h4>
                
            </div>
                                <div class="widget-block widget-wrapper af-widget-body magnitude-widget">
                <div class="af-container-row clearfix">
                    

                            <div class="col-2 pad float-l af-double-column list-style" data-mh="af-feat-list">
                                <div class="af-double-column list-style clearfix">
                                    <div class="read-single color-pad">
                                        <div class="data-bg read-img pos-rel col-4 float-l read-bg-img"
                                             data-background="https://dodofinance.com/wp-content/uploads/2022/05/Possible-British-extradition-request-to-the-United-States-for-Kevin-150x150.jpg">
                                                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Possible British extradition request to the United States for Kevin Spacey" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/05/Possible-British-extradition-request-to-the-United-States-for-Kevin-150x150.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/05/Possible-British-extradition-request-to-the-United-States-for-Kevin-150x150.jpg" alt="Possible British extradition request to the United States for Kevin Spacey"></noscript>
                                                                                        <a class="aft-post-image-link" href="https://dodofinance.com/possible-british-extradition-request-to-the-united-states-for-kevin-spacey-2/">Possible British extradition request to the United States for Kevin Spacey</a>
                                        </div>

                                        <div class="read-details col-75 float-l pad color-tp-pad">
                                                                                            <div class="read-categories">
                                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/entertainment/">
                                 entertainment
                             </a>
                        </li></ul>                                                </div>
                                                                                        <div class="read-title">
                                                <h4>
                                                    <a href="https://dodofinance.com/possible-british-extradition-request-to-the-united-states-for-kevin-spacey-2/">
                                                        Possible British extradition request to the United States for Kevin Spacey                                                    </a>
                                                </h4>
                                            </div>
                                        </div>
                                    </div>
                                </div>
                            </div>

                            

                            <div class="col-2 pad float-l af-double-column list-style" data-mh="af-feat-list">
                                <div class="af-double-column list-style clearfix">
                                    <div class="read-single color-pad">
                                        <div class="data-bg read-img pos-rel col-4 float-l read-bg-img"
                                             data-background="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-150x150.png">
                                                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="A spider&#039;s web as an eardrum |  BNR news radio" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-150x150.png"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/02/A-spiders-web-as-an-eardrum-BNR-news-radio-150x150.png" alt="A spider&#039;s web as an eardrum |  BNR news radio"></noscript>
                                                                                        <a class="aft-post-image-link" href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/">It sucked to fall prey to this primitive squid</a>
                                        </div>

                                        <div class="read-details col-75 float-l pad color-tp-pad">
                                                                                            <div class="read-categories">
                                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/science/">
                                 science
                             </a>
                        </li></ul>                                                </div>
                                                                                        <div class="read-title">
                                                <h4>
                                                    <a href="https://dodofinance.com/it-sucked-to-fall-prey-to-this-primitive-squid/">
                                                        It sucked to fall prey to this primitive squid                                                    </a>
                                                </h4>
                                            </div>
                                        </div>
                                    </div>
                                </div>
                            </div>

                            

                            <div class="col-2 pad float-l af-double-column list-style" data-mh="af-feat-list">
                                <div class="af-double-column list-style clearfix">
                                    <div class="read-single color-pad">
                                        <div class="data-bg read-img pos-rel col-4 float-l read-bg-img"
                                             data-background="https://dodofinance.com/wp-content/uploads/2022/06/Short-Game-Serbia-wins-3x3-Basketball-World-Championship-Sports-150x150.jpg">
                                                                                            <img src="data:image/svg+xml,%3Csvg%20xmlns='http://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" alt="Short Game: Serbia wins 3x3 Basketball World Championship |  Sports" data-lazy-src="https://dodofinance.com/wp-content/uploads/2022/06/Short-Game-Serbia-wins-3x3-Basketball-World-Championship-Sports-150x150.jpg"><noscript><img src="https://dodofinance.com/wp-content/uploads/2022/06/Short-Game-Serbia-wins-3x3-Basketball-World-Championship-Sports-150x150.jpg" alt="Short Game: Serbia wins 3x3 Basketball World Championship |  Sports"></noscript>
                                                                                        <a class="aft-post-image-link" href="https://dodofinance.com/sporty-shorts-serbia-win-3x3-basketball-world-title-sport/">Sporty shorts: Serbia win 3&#215;3 basketball world title |  sport</a>
                                        </div>

                                        <div class="read-details col-75 float-l pad color-tp-pad">
                                                                                            <div class="read-categories">
                                                    <ul class="cat-links"><li class="meta-category">
                             <a class="magnitude-categories category-color-1" href="https://dodofinance.com/sport/">
                                 sport
                             </a>
                        </li></ul>                                                </div>
                                                                                        <div class="read-title">
                                                <h4>
                                                    <a href="https://dodofinance.com/sporty-shorts-serbia-win-3x3-basketball-world-title-sport/">
                                                        Sporty shorts: Serbia win 3&#215;3 basketball world title |  sport                                                    </a>
                                                </h4>
                                            </div>
                                        </div>
                                    </div>
                                </div>
                            </div>

                            
                </div>
            </div>

            </div>                        </section>
                    </div>
                               
            </div>
        </div>
    </div>
    
            <div class="secondary-footer">
        <div class="container-wrapper">
            <div class="af-container-row clearfix af-flex-container">
                                    <div class="float-l pad color-pad col-1">
                        <div class="footer-nav-wrapper">
                        <div class="footer-navigation"><ul id="footer-menu" class="menu"><li id="menu-item-2575" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2575"><a href="https://dodofinance.com/about-us/">About Us</a></li>
<li id="menu-item-2577" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2577"><a href="https://dodofinance.com/dmca/">DMCA</a></li>
<li id="menu-item-2576" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2576"><a href="https://dodofinance.com/contact-form/">Contact Form</a></li>
<li id="menu-item-2574" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-2574"><a href="https://dodofinance.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>                        </div>
                    </div>
                                                </div>
        </div>
    </div>
            <div class="site-info">
        <div class="container-wrapper">
            <div class="af-container-row">
                <div class="col-1 color-pad">
                                                                Copyright &copy; All rights reserved.                                                                            </div>
            </div>
        </div>
    </div>
</footer>
</div>
<a id="scroll-up" class="secondary-color">
    <i class="fa fa-angle-up"></i>
</a>












<script type='text/javascript' id='magnitude-pagination-js-js-extra'>
/* <![CDATA[ */
var AFurl = {"nonce":"a0a2f0b304","ajaxurl":"https:\/\/dodofinance.com\/wp-admin\/admin-ajax.php","view_count":""};
/* ]]> */
</script>



<script type='text/javascript' id='fifu-image-js-js-extra'>
/* <![CDATA[ */
var fifuImageVars = {"fifu_lazy":"","fifu_woo_lbox_enabled":"1","fifu_woo_zoom":"inline","fifu_is_product":"","fifu_is_flatsome_active":"","fifu_rest_url":"https:\/\/dodofinance.com\/wp-json\/","fifu_nonce":"2fc29386e1"};
/* ]]> */
</script>

<script src='https://stats.wp.com/e-202226.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9.1',blog:'168773494',post:'36820',tz:'3',srv:'dodofinance.com'} ]);
	_stq.push([ 'clickTrackerInit', '168773494', '36820' ]);
</script>
<script>window.lazyLoadOptions={elements_selector:"img[data-lazy-src],.rocket-lazyload",data_src:"lazy-src",data_srcset:"lazy-srcset",data_sizes:"lazy-sizes",class_loading:"lazyloading",class_loaded:"lazyloaded",threshold:300,callback_loaded:function(element){if(element.tagName==="IFRAME"&&element.dataset.rocketLazyload=="fitvidscompatible"){if(element.classList.contains("lazyloaded")){if(typeof window.jQuery!="undefined"){if(jQuery.fn.fitVids){jQuery(element).parent().fitVids()}}}}}};window.addEventListener('LazyLoad::Initialized',function(e){var lazyLoadInstance=e.detail.instance;if(window.MutationObserver){var observer=new MutationObserver(function(mutations){var image_count=0;var iframe_count=0;var rocketlazy_count=0;mutations.forEach(function(mutation){for(var i=0;i<mutation.addedNodes.length;i++){if(typeof mutation.addedNodes[i].getElementsByTagName!=='function'){continue}
if(typeof mutation.addedNodes[i].getElementsByClassName!=='function'){continue}
images=mutation.addedNodes[i].getElementsByTagName('img');is_image=mutation.addedNodes[i].tagName=="IMG";iframes=mutation.addedNodes[i].getElementsByTagName('iframe');is_iframe=mutation.addedNodes[i].tagName=="IFRAME";rocket_lazy=mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');image_count+=images.length;iframe_count+=iframes.length;rocketlazy_count+=rocket_lazy.length;if(is_image){image_count+=1}
if(is_iframe){iframe_count+=1}}});if(image_count>0||iframe_count>0||rocketlazy_count>0){lazyLoadInstance.update()}});var b=document.getElementsByTagName("body")[0];var config={childList:!0,subtree:!0};observer.observe(b,config)}},!1)</script><script data-no-minify="1" async src="https://dodofinance.com/wp-content/plugins/wp-rocket/assets/js/lazyload/17.5/lazyload.min.js"></script>
<script src="https://dodofinance.com/wp-content/cache/min/1/375fbaf611980f89f71501fd88eba858.js" data-minify="1" defer></script></body>
</html>

<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me -->